You Are Here:
You are here: SETUP > Configuring NTP > NTP over Anycast > Anycast via NTP Expert Mode

Configuring Anycast via NTP Expert Mode

Advanced Anycast configuration is possible via the NTP Expert Mode (see also NTP Expert Mode), which allows you to write directly into the Anycast configuration files (zebra.conf; ospfd.conf; ospf6d.conf and bgpd.conf).

The zebra.conf file is required for both IPv4, and IPv6 Anycast. The ospfd.conf file is required for IPv4 OSPF only, the ospf6d.conf file is required for IPv6 OSPF only, and the bgpd.conf file has multiprotocol functionality, hence it can be used for both IPv4, and IPv6 Anycast.

Caution: Expert Mode should only be utilized by advanced users, as incorrectly altering the Anycast files can cause Anycast to stop working.

Caution: Any configurations made in Expert Mode will be lost as soon as Expert Mode is disabled.

  1. To access Expert Mode, navigate to MANAGEMENT > NTP Setup.
  2. Enable the switch for Expert Mode in the panel NTP Services.
  3. Once it is enabled, click NTP Anycast in the Actions Panel. The Expert mode window will appear, with a separate tab for each of the three configuration files.
  4. To enable OSPF IPv4 Anycast, check Enable under the OSPF tab. To enable OSPF IPv6 Anycast, check Enable under the OSPF6 tab. To enable BGP Anycast, check Enable under the BGP tab. Then click Submit.

When the NTP Anycast Expert Mode window is opened, the files displayed are the configuration files in their current states. If no configuration was done outside of Expert Mode, these will be the factory default files. If Anycast configuration was already done from the Web UI, you will be able to edit the existing Anycast setup.

When editing zebra.conf in expert mode, you should ensure that the first line under an interface line is an ip address line declaring an IPv4 address (if there is one for the interface), and that the next line is an ipv6 address line declaring an IPv6 address (if there is one for the interface). No other lines or variations in spacing should be inserted before or between these lines. No editing restrictions exist on ospfd.conf or ospf6d.conf files.

Example zebra.conf file with both IPv4, and IPv6 configured on the same port:

(Interface eth0 line, followed by IPv4 line and then IPv6 line)

*****************************************************

!

interface eth0

ip address 10.2.100.157/16

ipv6 address 2000:10:2::157/64

!

interface lo

ip address 10.10.14.1/32

ipv6 address 2000:10:10::1/64

*****************************************************

Example zebra.conf file with IPv4, and IPv6 configured on different ports:

(Interface eth0 line, followed by only IPv4 line, because no IPv6 address is configured on that port. Interface eth1 line, followed by only IPv6 line, because no IPv4 address is configured on that port)

*****************************************************

!

interface eth0

ip address 10.2.100.157/16

interface eth1

ipv6 address 2000:10:2::157/64

!

interface lo

ip address 10.10.14.1/32

ipv6 address 2000:10:10::1/64

*****************************************************

Example zebra.conf file showing the default file with no addresses configured:

(Interface eth0 line, with no lines following it because no addresses are configured on the port)

*****************************************************

!

interface eth0

!

interface lo

*****************************************************

Example ospfd.conf file:

*****************************************************!

router ospf

ospf router-id 10.2.100.157

network 10.2.0.0/16 area 0.0.0.0

redistribute connected

distribute-list default out connected

!

access-list default permit 10.10.14.1/32

access-list default deny any

*****************************************************

Example ospf6d.conf file:

 

*****************************************************

!

interface eth0

!

router ospf6

router-id 10.2.100.157

interface eth0 area 0.0.0.0

redistribute connected

!

*****************************************************

Example bgpd.conf file:

*****************************************************!

router bgp 12

bgp router-id 172.17.1.12

network 172.17.0.0/16

neighbor 172.17.1.1 remote-as 3

!

redistribute connected

*****************************************************